HDU 1160 FatMouse's Speed (最长递减子序列)

FatMouse's Speed

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
4
4
5
9
7

题意

我们是要在原来的老鼠序列中,找到一个最长的子序列,使得这个子序列中老鼠的体重在严格增加,速度却在严格降低。
首先输出满足条件的最长的子序列的长度。
其次,输出一个最长子序列的方案,要求输出每个老鼠在输入时候的编号,每个编号占一行,任意一种正确的方法都会被判正确。

题解

模板题,输出编号可以记录一下前驱,最后递归输出就行。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=1005;
typedef long long LL;
int dp[maxn],path[maxn];
struct mouse
{
    int id,w,s;
    bool operator <(const mouse& x)const 
    {
        if(w==x.w)
            return  s>x.s;
        return w<x.w;
    }
}m[maxn];
void print(int x)
{
    if(x==-1)
        return ;
    print(path[x]);
    printf("%d\n",x);
}
int main()
{
    int n=0,we,sp;
    while(~scanf("%d%d",&we,&sp))
    {
        m[n].id=n+1;
        m[n].w=we;
        m[n++].s=sp;
    }
    sort(m,m+n);
    memset(path,-1,sizeof(path));
    int ans=0,ans_id;
    for(int i=0;i<n;i++)
    {
        dp[i]=1;
        for(int j=0;j<i;j++) 
        {
            if(m[j].w<m[i].w&&m[j].s>m[i].s&&dp[i]<=dp[j])
            {
                dp[i]=dp[j]+1;
                path[m[i].id]=m[j].id;
            }
        }
        if(dp[i]>ans)
        {
            ans=dp[i];
            ans_id=m[i].id;
        }
    }
    printf("%d\n",ans);
    print(ans_id);
    return 0;
}
posted @ 2018-02-19 21:03  Zireael  阅读(159)  评论(0编辑  收藏  举报