UVA 129 Krypton Factor(DFS 回溯)

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants
have very high mental and physical abilities. In one section of the contest the contestants are tested on
their ability to recall a sequenace of characters which has been read to them by the Quiz Master. Many
of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to
this test, the organisers have decided that sequences containing certain types of repeated subsequences
should not be used. However, they do not wish to remove all subsequences that are repeated, since in
that case no single character could be repeated. This in itself would make the problem too easy for the
contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining
identical subsequences. Sequences containing such an occurrence will be called “easy”. Other sequences
will be called “hard”.
For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the
subsequence CB. Other examples of easy sequences are:
• BB
• ABCDACABCAB
• ABCDABCD
Some examples of hard sequences are:
• D
• DC
• ABDAB
• CBABCBA
In order to provide the Quiz Master with a potentially unlimited source of questions you are asked
to write a program that will read input lines from standard input and will write to standard output.
Input
Each input line contains integers n and L (in that order), where n > 0 and L is in the range 1 ≤ L ≤ 26.
Input is terminated by a line containing two zeroes.
Output
For each input line prints out the n-th hard sequence (composed of letters drawn from the first L letters
in the alphabet), in increasing alphabetical order (Alphabetical ordering here corresponds to the normal
ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The
first sequence in this ordering is ‘A’. You may assume that for given n and L there do exist at least n
hard sequences.
As such a sequence is potentially very long, split it into groups of four (4) characters separated by
a space. If there are more than 16 such groups, please start a new line for the 17th group.
Your program may assume a maximum sequence length of 80.
For example, with L = 3, the first 7 hard sequences are:
A
AB
ABA
ABAC
ABACA
ABACAB
ABACABA
Sample Input
7 3
30 3
0 0
Sample Output
ABAC ABA
7
ABAC ABCA CBAB CABA CABC ACBA CABA
28

题意

如果一个字符串包含两个相邻的重复子串,则称它是“容易的串”,其他串是“困难的串”。
输入正整数n和L,输出前L个字符组成的、字典序第k小的困难的串。

题解

很容易想到的是从左往右依次考虑每个位置的字符,检查所有长度为偶数的子串,分别判断每个子串的前一半是否等于后一半。但是这样太复杂了,可以进行优化,其实只需要判断当前串的后缀就行了,只需判断当前串的后缀是否满足条件,而不用考虑之前所有的子串(前面判断过了)。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int cnt;
int n,m;
int s[1005];
bool dfs(int cur)
{
    if(cnt++==n)
    {
        for(int i=0;i<cur;i++)
        {
            if(i&&i%64==0)
                puts("");
            else if(i&&i%4==0)
                putchar(' ');
            printf("%c",'A'+s[i]);
        }
        printf("\n%d\n",cur);
        return true;
    }
    for(int i=0;i<m;i++)
    {
        s[cur]=i;
        int ok=1;
        for(int j=1;j*2<=cur+1;j++)//尝试长度为j*2的后缀
        {
            int equal=1;
            for(int k=0;k<j;k++)//检查前一半是否等于后一半
                if(s[cur-k]!=s[cur-j-k])
                {
                    equal=0;
                    break;
                }
            if(equal)//后一半等于前一半,方案不合法
            {
                ok=0;
                break;
            }
        }
        if(ok&&dfs(cur+1))//递归搜索。如果找到解就直接退出
            return true;
    }
    return false;
}
int main()
{
    while(~scanf("%d%d",&n,&m),n||m)
    {
        cnt=0;
        memset(s,0,sizeof(s));
        dfs(0); 
    }
    return 0;
}
posted @ 2018-01-31 20:39  Zireael  阅读(179)  评论(0编辑  收藏  举报