POJ 3259 Wormholes(Bellman-ford判断负环)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself 😃 .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:

通过虫洞可以返回N年前,判断从某个点出发能不能回到从前,其实就是判断有没有负环。

题解:

Bellman-Ford算法,如果图中不存在负圈,那么最短路不会经过同一个顶点两次(最多通过V-1条边),把d[i]初始化为0,就可以判断所有的负环了。

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=505,INF=0x3f3f3f3f;
int d[maxn];
int n,m;
int cnt;
struct edge
{
    int u,v,cost;
}es[maxn*maxn];
bool find_negative_loop()
{
    memset(d,0,sizeof(d));
    for(int i=0;i<n;i++)
        for(int j=0;j<cnt;j++)
        {
            edge e=es[j];
            if(d[e.v]>d[e.u]+e.cost)
            {    
                d[e.v]=d[e.u]+e.cost;
                if(i==n-1)
                    return true;
            }
        }
    return false;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int q;
        cin>>n>>m>>q;
        cnt=0;
        for(int i=0;i<m;i++)
        {
            int a,b,c;
            cin>>a>>b>>c;//反向的边也要存储
            es[cnt].u=es[cnt+1].v=a;
            es[cnt].v=es[cnt+1].u=b;
            es[cnt].cost=es[cnt+1].cost=c;
            cnt+=2;
        }
        for(int i=0;i<q;i++)
        {
            cin>>es[cnt].u>>es[cnt].v>>es[cnt].cost;//添加负权边
            es[cnt++].cost*=-1;
        }
        if(find_negative_loop())
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}
posted @ 2017-11-02 19:21  Zireael  阅读(186)  评论(0编辑  收藏  举报