POJ 2976 Dropping tests(二分)

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input
The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output
For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input
3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0
Sample Output
83
100
Hint
To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

题意:

n场考试中分别答对a_i题,总题数分别为b_i,允许翘掉k场考试,求能达到的最高准确率。

题解:

二分查找准确率即可。(这类题贪心肯定不行,通过样例也可以看出来)。

题目测试数据可以在这里找:http://ai.stanford.edu/~chuongdo/acm/2005/

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=1e5+5;
const double INF=1e6+5,esp=1e-6;
int v[maxn],w[maxn];
double y[maxn];
int n,k;
bool check(double x)//可以选择使得单位重量的价值不小于x
{
	for(int i=0;i<n;i++)
	{
		y[i]=v[i]-x*w[i];
	}
	sort(y,y+n);
	double sum=0;
	for(int i=k;i<n;i++)
		sum+=y[i];
	return sum>=0;
}
void solve()
{
	double lb=0,ub=INF;
	while(lb+esp<ub)
	{
		double mid=(lb+ub)/2;
		if(check(mid))
			lb=mid;
		else
			ub=mid;
	}
	printf("%.f\n",floor(100*lb+0.5));
}
int main()
{
	while(cin>>n>>k,n||k)
	{
		for(int i=0;i<2*n;i++)
		{
			if(i<n)
				scanf("%d",&v[i]);
			else
				scanf("%d",&w[i%n]);;
		}
		solve();
	}
	return 0;
}
posted @ 2017-10-26 20:41  Zireael  阅读(172)  评论(0编辑  收藏  举报