Oil Deposits(dfs)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15291    Accepted Submission(s): 8787


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

 

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
 

 

Sample Output
0
1
2
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int n,m;
char grid[120][120];
int vis[120][120];
struct node{
    int x,y;
};
void in_put()
{
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;++i)
    scanf("%s",grid[i]+1);
}
int check(node v)
{
    if(!vis[v.x][v.y]&&v.x>=1&&v.x<=n&&v.y>=1&&v.y<=m&&grid[v.x][v.y]=='@')
    return 1;
    else return 0;
}
void dfs(node v)
{
    node nex;
    vis[v.x][v.y]=1;grid[v.x][v.y]='?';
 
    nex.x=v.x+1;nex.y=v.y;if(check(nex))    dfs(nex);
    nex.x=v.x+1;nex.y=v.y+1;if(check(nex))  dfs(nex);
    nex.x=v.x+1;nex.y=v.y-1;if(check(nex))  dfs(nex);
    nex.x=v.x;nex.y=v.y-1;if(check(nex))    dfs(nex);
    nex.x=v.x;nex.y=v.y+1;if(check(nex))    dfs(nex);
    nex.x=v.x-1;nex.y=v.y-1;if(check(nex))  dfs(nex);
    nex.x=v.x-1;nex.y=v.y+1;if(check(nex))  dfs(nex);
    nex.x=v.x-1;nex.y=v.y;if(check(nex))    dfs(nex);
}
int main()
{
    while(scanf("%d%d",&n,&m))
    {
        int cnt=0;node now;
        if(!n&&!m) break;
        in_put();
        for(int i=1;i<=n;++i)
            for(int j=1;j<=m;++j)
                if(grid[i][j]=='@')
            {now.x=i;now.y=j;dfs(now);cnt++;}
 
            printf("%d\n",cnt);
    }
}

 

2
posted @   JL_Zhou  阅读(137)  评论(0编辑  收藏  举报
编辑推荐:
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
· 被坑几百块钱后,我竟然真的恢复了删除的微信聊天记录!
· 没有Manus邀请码?试试免邀请码的MGX或者开源的OpenManus吧
点击右上角即可分享
微信分享提示