Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7661    Accepted Submission(s): 4567


Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
 

 

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.
 

 

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.".
 

 

Sample Input
e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6
 

 

Sample Output
To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
#include<cstdio>
#include<cstring>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
char s[3],s2[3];
int vis[10][10];
struct node{
    int x,y;
    int step_cnt;
};
node now,nex;
node vs,vd;
int check(node v)
{
    if(v.x>=1&&v.x<=8&&v.y>=1&&v.y<=8&&!vis[v.x][v.y])
    return 1;
    else return 0;
}
void bfs()
{
    queue<node>que;
    vs.step_cnt=0;
    que.push(vs);
    vis[vs.x][vs.y]=1;
    while(!que.empty()){
        now=que.front();
        que.pop();
        if(now.x==vd.x&&now.y==vd.y) return;
        nex.x=now.x+2;nex.y=now.y+1;nex.step_cnt=now.step_cnt+1;
        if(check(nex)) {que.push(nex);vis[nex.x][nex.y]=1;}
 
        nex.x=now.x+2;nex.y=now.y-1;nex.step_cnt=now.step_cnt+1;
        if(check(nex)) {que.push(nex);vis[nex.x][nex.y]=1;}
 
        nex.x=now.x-2;nex.y=now.y+1;nex.step_cnt=now.step_cnt+1;
        if(check(nex)) {que.push(nex);vis[nex.x][nex.y]=1;}
 
        nex.x=now.x-2;nex.y=now.y-1;nex.step_cnt=now.step_cnt+1;
        if(check(nex)) {que.push(nex);vis[nex.x][nex.y]=1;}
 
        nex.x=now.x+1;nex.y=now.y+2;nex.step_cnt=now.step_cnt+1;
        if(check(nex)) {que.push(nex);vis[nex.x][nex.y]=1;}
 
        nex.x=now.x+1;nex.y=now.y-2;nex.step_cnt=now.step_cnt+1;
        if(check(nex)) {que.push(nex);vis[nex.x][nex.y]=1;}
 
        nex.x=now.x-1;nex.y=now.y+2;nex.step_cnt=now.step_cnt+1;
        if(check(nex)) {que.push(nex);vis[nex.x][nex.y]=1;}
 
        nex.x=now.x-1;nex.y=now.y-2;nex.step_cnt=now.step_cnt+1;
        if(check(nex)) {que.push(nex);vis[nex.x][nex.y]=1;}
 
    }
}
int main()
{
    while(~scanf("%s%s",s,s2))
    {
        memset(vis,0,sizeof(vis));
        vs.x=s[1]-'0';
        vs.y=s[0]-96;
        vd.x=s2[1]-'0';
        vd.y=s2[0]-96;
        bfs();
        printf("To get from %s to %s takes %d knight moves.\n",s,s2,now.step_cnt);
    }
}

 给一个棋盘,算出马从一个点走到另一个点的最小步数(马走日)

Source
posted @   JL_Zhou  阅读(265)  评论(0编辑  收藏  举报
编辑推荐:
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
· 被坑几百块钱后,我竟然真的恢复了删除的微信聊天记录!
· 没有Manus邀请码?试试免邀请码的MGX或者开源的OpenManus吧
点击右上角即可分享
微信分享提示