Train Problem I (HDU 100题纪念)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23574    Accepted Submission(s): 8907


Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

 

Sample Input
3 123 321
3 123 312
 

 

Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
#include<cstdio>
#include<cstring>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
char in[12];
char out[12];
int n;
void solve()
{
    queue<char>Q;//火车出站序列
    queue<int>ans;//进出顺序,1表示in,0表示out
    stack<char>S;//火车入栈序列
    for(int i=0; i<n; ++i)
        Q.push(out[i]);
    for(int i=0; i<n; i++){
    if(!S.empty()&&S.top()==Q.front()){//wa了一次在这里,没有考虑到例子5 14325 13245
            Q.pop();S.pop();
            ans.push(0);
            i--;//由于是用前一个和Q.front()比较,所以是s[i]先不入栈
        }
    else if(in[i]==Q.front()){
            Q.pop();
            ans.push(1);
            ans.push(0);
        }
        else{
            ans.push(1);
            S.push(in[i]);
        }
    }
    while(!S.empty()&&!Q.empty()){
        if(S.top()==Q.front()){
            S.pop();Q.pop();
            ans.push(0);
        }
        else break;
    }
    while(!S.empty()){
        if(S.top()==Q.front()){
            ans.push(0);
            S.pop();Q.pop();
        }
        else break;
    }
    if(S.empty()){
        printf("Yes.\n");
        while(!ans.empty()){
            if(ans.front()) printf("in\n");
            else printf("out\n");
            ans.pop();
        }
        printf("FINISH\n");
    }
    else printf("No.\nFINISH\n");
}
int main()
{
    while(~scanf("%d%s%s",&n,in,out))
        solve();
    return 0;
}

 

FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
posted @   JL_Zhou  阅读(191)  评论(0编辑  收藏  举报
编辑推荐:
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
· 被坑几百块钱后,我竟然真的恢复了删除的微信聊天记录!
· 没有Manus邀请码?试试免邀请码的MGX或者开源的OpenManus吧
点击右上角即可分享
微信分享提示