Encoding

Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

 

Output
For each test case, output the encoded string in a line.
 

 

Sample Input
2 ABC ABBCCC
 

 

Sample Output
ABC A2B3C
 

 

Author
ZHANG Zheng
 

 

复制代码
#include<cstdio>
#include<cstring>
int main()
{
    int N;
    int a[130];
    int v;
    int temp=0;
    scanf("%d",&N);
    getchar();
    while(N--)
    {
        memset(a,0,sizeof(a));
        v=getchar();
        temp=v;
        while(temp!='\n')
        {

            if(v!=temp)
            {
                if(a[temp]>1) printf("%d%c",a[temp],temp);
                if(a[temp]==1) printf("%c",temp);
                a[temp]=0;
                a[v]++;
            }
            else a[v]++;
            temp=v;
            if(v!='\n') v=getchar();
        }
        printf("\n");
    }
}
/*题意没看清,wa了几次,题目说了是子序列,那么对于例子 AABBBCCCAABB  应输出2A3B3C2A2B*/
View Code
复制代码

 

posted @   JL_Zhou  阅读(208)  评论(0编辑  收藏  举报
编辑推荐:
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
· 被坑几百块钱后,我竟然真的恢复了删除的微信聊天记录!
· 没有Manus邀请码?试试免邀请码的MGX或者开源的OpenManus吧
点击右上角即可分享
微信分享提示