Let the Balloon Rise

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

 

Sample Output
red pink
 

 

Author
WU, Jiazhi

 

复制代码
#include<cstdio>
#include<cstring>
int main()
{
    char s[1005][20];
    char temp[20];
    int a[1005];
    int n,i,j;
    while(1)
    {
        memset(a,0,sizeof(a));
        memset(temp,0,sizeof(temp));
        memset(s,0,sizeof(s));
        scanf("%d",&n);
        if(!n) break;
        for(i=0; i<n; i++)
            scanf("%s",s[i]);
        for(i=0; i<n-1; i++)
        {
            if(a[i]<0) continue;/*不这样做就会超时*/
            for(j=i+1; j<n; j++)
            {
                if(a[j]<0) continue;
                if(strcmp(s[i],s[j])==0)
                {
                    a[i]++;
                    a[j]=-1;
                    strcpy(s[j],temp);
                }

            }
        }
        int max=0,maxi=0;
        for(i=0; i<n; i++)
            if(a[i]>max)
            {
                max=a[i];
                maxi=i;
            }
        printf("%s\n",s[maxi]);


    }
}
View Code
复制代码

 

posted @   JL_Zhou  阅读(108)  评论(0编辑  收藏  举报
编辑推荐:
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
· 被坑几百块钱后,我竟然真的恢复了删除的微信聊天记录!
· 没有Manus邀请码?试试免邀请码的MGX或者开源的OpenManus吧
点击右上角即可分享
微信分享提示