A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

 

复制代码
#include<cstdio>
#include<cstring>
void plus(int *a,int *b)
{
    int k;
    k=a[0]>b[0]?a[0]:b[0];
    for(int i=1; i<=k; i++)
    {
        a[i+1]+=(a[i]+b[i])/10;
        a[i]=(a[i]+b[i])%10;
    }
    if(a[k+1]) a[0]=k+1;
    else a[0]=k;
}
int main()
{
    char s1[1005],s2[1005];
    int a[1005],b[1005];
    int T,i,n,m,t;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {

        n=m=1;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        scanf("%s",s1);
        scanf("%s",s2);
        for(i=strlen(s1)-1; i>=0; i--)
            a[n++]=s1[i]-'0';
        a[0]=n-1;
        for(i=strlen(s2)-1; i>=0; i--)
            b[m++]=s2[i]-'0';
        b[0]=m-1;

        printf("Case %d:\n",t);
        printf("%s + %s",s1,s2);
        printf(" = ");
        plus(a,b);
        for(i=a[0]; i>=1; i--)
            printf("%d",a[i]);
        printf("\n");
        if(t!=T) printf("\n");
    }
    return 0;
}
/*前几次一直PE,后来才发现原来是最后面多输出了一个回车,囧*/
View Code
复制代码

 

posted @   JL_Zhou  阅读(136)  评论(0编辑  收藏  举报
编辑推荐:
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
· 被坑几百块钱后,我竟然真的恢复了删除的微信聊天记录!
· 没有Manus邀请码?试试免邀请码的MGX或者开源的OpenManus吧
点击右上角即可分享
微信分享提示