Number Sequence

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

 

Output
For each test case, print the value of f(n) on a single line.
 

 

Sample Input
1 1 3
1 2 10
 0 0 0
 

 

Sample Output
2
5
复制代码
#include<cstdio>
int main()
{
    int n;
    int A,B;
    int a[10000]= {0,1,1};
    while(scanf("%d%d%d",&A,&B,&n)&&(A||B||n))
    {
        int i;
        for(i=3; i<10000; i++)
        {
            a[i]=(A*a[i-1]+B*a[i-2])%7;
            if(a[i-1]==1&&a[i]==1) break;
        }
        n=n%(i-2);
        if(n==0) n=i-2;
        printf("%d\n",a[n]);
    }
    return 0;
}
View Code
复制代码

 因在计算过程中涉及求余,可利用周期性及时跳出循环

posted @   JL_Zhou  阅读(173)  评论(0编辑  收藏  举报
编辑推荐:
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
· 被坑几百块钱后,我竟然真的恢复了删除的微信聊天记录!
· 没有Manus邀请码?试试免邀请码的MGX或者开源的OpenManus吧
点击右上角即可分享
微信分享提示