Number Sequence

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

 

Output
For each test case, print the value of f(n) on a single line.
 

 

Sample Input
1 1 3
1 2 10
 0 0 0
 

 

Sample Output
2
5
#include<cstdio>
int main()
{
    int n;
    int A,B;
    int a[10000]= {0,1,1};
    while(scanf("%d%d%d",&A,&B,&n)&&(A||B||n))
    {
        int i;
        for(i=3; i<10000; i++)
        {
            a[i]=(A*a[i-1]+B*a[i-2])%7;
            if(a[i-1]==1&&a[i]==1) break;
        }
        n=n%(i-2);
        if(n==0) n=i-2;
        printf("%d\n",a[n]);
    }
    return 0;
}
View Code

 因在计算过程中涉及求余,可利用周期性及时跳出循环

posted @ 2015-01-30 00:49  JL_Zhou  阅读(171)  评论(0编辑  收藏  举报