hdu 2486 A simple stone game

A simple stone game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 111    Accepted Submission(s): 44


Problem Description
After he has learned how to play Nim game, Mike begins to try another stone game which seems much easier.

The game goes like this: Two players start the game with a pile of n stones. They take stones from the pile in turn and every time they take at least one stone. The one who goes first can take at most n-1 stones for his first move. From then on a player can take at most k times as many stones as his opponent has taken last time. For example, if one player take m stones in his turn, then the other player can take at most k × m stones next time. The player who takes the last stone wins the game. Suppose that those two players always take the best moves and never make mistakes, your job is to find out who will definitely win the game.
 

 

Input
The first line contains a integer t, indicating that there are t test cases following.(t<=20).

Each test case is a line consisting of two integer n and k.(2<=n<=10^8,1<=k<=10^5).
 

 

Output
For each test case, output one line starting with “Case N: ”, N is the case number. And then, if the first player can ensure a winning, print the minimum number of stones he should take in his first turn. Otherwise, print "lose". Please note that there is a blank following the colon.
 

 

Sample Input
5 16 1 11 1 32 2 34 2 19 3
 

 

Sample Output
Case 1: lose Case 2: 1 Case 3: 3 Case 4: lose Case 5: 4
View Code
#include <iostream>
#include <cstdio>

using namespace std;
#define MAXN 1000000
int n,k;
int a[MAXN+1],r[MAXN+1];

void solve()
{
int i,j;
a[0]=r[0]=0;
for(i=1,j=0;i<=MAXN;i++)
{
a[i]=r[i-1]+1;
while(j+1<i&&a[j+1]*k<a[i]) j++;
r[i]=a[i]+r[j];
r[i]=a[i]+r[j];
if(r[i]>=n) break;
}
if(i>MAXN)
{
printf("un solvable!\n");
return ;
}
if(a[i]==n)
{
printf("lose\n");return;
}
for(;i>=1;i--)
{
if(n==a[i])
{
printf("%d\n",n);
return;
}
else if(n>a[i]) n-=a[i];
}
printf("logic error\n");
}

int main()
{
int ca,cc=0;
scanf("%d",&ca);
while(ca--)
{
scanf("%d%d",&n,&k);
printf("Case %d: ",++cc);
solve();
}
return 0;
}

posted on 2011-12-28 20:45  Goal  阅读(450)  评论(0编辑  收藏  举报

导航