动态规划解决POJ 3624

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

#include<iostream>
using namespace std;
int f[12881];  //f[k]表示:当背包的容量为k时的最大价值
int max(int a,int b)
{
	return a>b?a:b;
}
int main()
{
	int Num,TotalWeight,i,k,j,weight[12881],value[12881];
        cin>>Num>>TotalWeight;
	f[0]=0;
	for(i=0;i<Num;i++)
		cin>>weight[i]>>value[i];
	for(i=0;i<Num;i++)
		for(k=TotalWeight;k>=weight[i];k--)
		{
			f[k]=max(f[k],(f[k-weight[i]]+value[i]));
			//在max中的两个参数f[k], 和f[k-weight[i]]+value[i]都是表示在背包容量为k时的最大价值
			//f[k]是这个意思,就不用说了。
			//而f[k-weight[i]]+value[i]也表示背包容量为k时的最大价值是为什么呢?
			//首先,f[k-weight[i]]表示的是背包容量为k-weight[i]的容量,也就是说f[k-weight[i]]
			//表示的是容量还差weiht[i]才到k的价值,+walue[i]恰好弥补了差的这个价值。所以……

			//如果你对f[k]=max(f[k],(f[k-weight[i]]+value[i]));这句话不是很清楚,
			//下面的这句代码会对你有帮助
			//cout<<"i="<<i+1<<"  f["<<k<<"]="<<f[k]<<endl;
		}
	cout<<f[TotalWeight]<<endl;
	return 0;
}

posted on 2011-08-22 21:42  飞-虎  阅读(728)  评论(2编辑  收藏  举报

导航