书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!

二分匹配解决poj 1466

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description: 

the number of students 
the description of each student, in the following format 
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ... 
or 
student_identifier:(0) 

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

Output

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

题意:在大学校园里男女学生存在某种关系,现在给出学生人数n,并给出每个学生与哪些学生存在关系(存在关系的学生一定是异性)。现在让你求一个学生集合,这个集合中任意两个学生之间不存在这种关系。输出这样的关系集合中最大的一个的学生人数。

思路:对于给定的人数n,我们可以看成两个集合a和b,每个集合中有n个人,对于a中的每个元素,和b中的某些元素存在关系(边)(也就是每个人和其它人的关系,),而且这两个点集及关系构成的图必定是一个二分图。如果我们求出二分图的最大匹配对数,那么将总元素个数减去最大匹配个数,剩下的个数就是最大独立集元素的个数。此题中我们将人数扩大了两倍(构建二分图的需要),所经结果应该除以二。最以最终答案的公式应该是:max=n-最大匹配数/2;

View Code
#include <iostream>
using namespace std;
const int N=510;
struct edge
{
int to,nxt;
}e[N*N];
int p[N],mch[N];
bool vis[N];
bool dfs(int u) //u就是from, v就是to
{
for(int x=p[u];x!=-1;x=e[x].nxt)
{
int v=e[x].to;
if(!vis[v])
{
vis[v]=true;
if(mch[v]==-1||dfs(mch[v]))
{
mch[v]=u;
return true;
}
}
}
return false;
}
int main()
{
int n;
while(~scanf("%d",&n))
{
int i,j=0;
memset(p,-1,sizeof(p));
for(i=0;i<n;i++)
{
int x,num;
scanf("%d: (%d)",&num,&num);
for(int k=1;k<=num;k++)
{
scanf("%d",&x);
e[j].to=x;e[j].nxt=p[i];p[i]=j++;
}
}
cout<<j<<endl;
memset(mch,-1,sizeof(mch));
int ans=0;
for(i=0;i<n;i++)
{
memset(vis,0,sizeof(vis));
if(dfs(i))
ans++;
}
printf("%d\n",n-ans/2);
}
return 0;
}


posted on 2012-03-16 18:58  More study needed.  阅读(458)  评论(0编辑  收藏  举报

导航

书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!