书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!

叉乘+二分解决POJ 2398

 

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1


不写不知道,一写吓一跳,原来这个是两码子的事。

中间有许多注意的东西,只有亲自写了,才知道的。

废话不多说,直接上代码。


复制代码
View Code
#include "iostream"
#include "algorithm"
using namespace std;
struct LineP
{
    double up_x, down_x;
}LP[1005];
bool Check(LineP p1, LineP p2) //排序子函数
{
    if(p1.up_x < p2.up_x) return true;
    return false;
}
double Judge(int j, double x, double y, double y1, double y2) //这个就是叉乘了
{
    return (LP[j].down_x - LP[j].up_x)*(y-y2) - (y2-y1)*(x-LP[j].down_x);
}
int main()
{
    int n, m;
    double x1, y1, x2, y2, x, y;
    int ans[1005], realans[1005], low, high, mid;
    while(cin>>n && n)
    {
        memset(ans, 0, sizeof(ans));
        memset(realans, 0, sizeof(realans));
        cin>>m>>x1>>y1>>x2>>y2;
        for(int i=1; i<=n; i++)
            cin>>LP[i].up_x>>LP[i].down_x;
        LP[0].up_x = x1; LP[0].down_x = x1;
        LP[n+1].up_x = x2; LP[n+1].down_x = x2;
        sort(LP, LP+n+1, Check);
        for(int i=0; i<m; i++)
        {
            cin>>x>>y;
            low = 0; high = n+1; 
            mid = (low+high)/2;
            if(Judge(0, x, y, y1, y2)==0)
                mid = 0;
            else if(Judge(n+1, x, y, y1, y2)==0)
                mid = n;
            else
            {
                while(low<high)
                {
                    if(Judge(mid, x, y, y1, y2)<0) high = mid-1;
                    else low = mid+1;
                    mid = (low+high)/2;
                }
                if(Judge(mid, x, y, y1, y2) < 0)
                    mid--;
            }    
            ans[mid]++;
        }
        cout<<"Box"<<endl;
        for(int i=1; i<=n; i++)
            for(int j=0; j<=n+1; j++)
                if(ans[j]==i)
                    realans[i]++;
        for(int i=0; i<=n; i++)
            if(realans[i])
                cout<<i<<": "<<realans[i]<<endl;
    }
}
复制代码

 

 

posted on   More study needed.  阅读(291)  评论(0编辑  收藏  举报

编辑推荐:
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
阅读排行:
· 10年+ .NET Coder 心语 ── 封装的思维:从隐藏、稳定开始理解其本质意义
· 地球OL攻略 —— 某应届生求职总结
· 提示词工程——AI应用必不可少的技术
· Open-Sora 2.0 重磅开源!
· 周边上新:园子的第一款马克杯温暖上架
< 2011年10月 >
25 26 27 28 29 30 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

导航

统计

书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!

点击右上角即可分享
微信分享提示