Stack解决——括号匹配
Sample Input
5
{[(<>)]}
[()]
<>()[]{}
[{}]
{()}
Sample Output
YES
YES
YES
NO
YES
边pop(), 边push(),这个是个很好的方法,
stack的最大用途也就在于此了。
另外,在用stack的时候;特别是在用while(!s.empty())
循环的时候,一定不能忘记pop();不然会进入死循环。
#include"iostream"
#include"cstring"
#include"string"
#include"stack"
using namespace std;
char map[9] = {'<', '(', '[', '{', '>', ')', ']', '}'};
int main()
{
int Case;
cin>>Case;
while(Case--)
{
stack<int> Num;
string s;
int len, flag = 0;
cin>>s;
len = s.length();
if(len%2==0)
{
for(int i=0; i<len; i++)
{
for(int j=0; j<8; j++)
{
if(s[i]==map[j])
{
if(!Num.empty())
{
int t = Num.top();
if(t>=j) Num.push(j);
else if(j==t+4) Num.pop();
else
{
flag = 1;
break;
}
}
else Num.push(j);
}
}
if(flag) break;
}
if(!flag && Num.empty()) cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}
else cout<<"NO"<<endl;
}
}
posted on 2011-10-18 21:42 More study needed. 阅读(798) 评论(0) 编辑 收藏 举报