书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!

动态规划解决USACO——Number Triangles

 

Description

 

Consider the number triangle shown below. Write a program that calculates the highest sum

of numbers that can be passed on a route that starts at the top and ends somewhere on

the base. Each step can go either diagonally down to the left or diagonally down to the right.

          7

        3   8

      8   1   0

    2   7   4   4

  4   5   2   6   5

In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

 

Input

The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the

integers for that particular row of the triangle. All the supplied integers are non-negative and

no larger than 100.

Output

A single line containing the largest sum using the traversal specified.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

 

这个是一道十分简单的题目,就是用动规去做,

下面有详细的解释。

#include "iostream"

using namespace std;

#define Max 1005

int a[Max][Max];

int R;

int Find()

{

for(int i=R-1;i>0;i--)

{

for(int j=1;j<=i;j++)

{

a[i][j] += max(a[i+1][j],a[i+1][j+1]); //从倒数第二层开始运算,将下一层的较大数往上加,

                                                                              //当加到第一层的时候,自然的就是最大值了

}

}

return a[1][1];

}

int main()

{

while(cin>>R)

{

for(int i=1; i<=R; i++)

for(int j=1; j<=i; j++)

cin>>a[i][j];

cout<<Find()<<endl;

}

}

posted on 2011-10-16 10:50  More study needed.  阅读(908)  评论(0编辑  收藏  举报

导航

书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!