书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!

Huffman和Priority_queue 解决POJ 3253

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

 

使用优先队列每次选择队头的两个数并将其出列,

相加后将结果放入队列中,直到队列为空为止.

上面这句话,道出了哈夫曼算法的真谛了。
View Code
#include<iostream>
#include<queue>
using namespace std;
const int Max = 20005;

typedef struct node{
    long long value;
    bool operator < (const node &a) const{
        return value > a.value;
    }
}node;
node tmp;

int main()
{
    int n, i;
    scanf("%d", &n);
    priority_queue<node> que;
    for(i = 0; i < n; i ++){
        scanf("%d", &tmp.value);
        que.push(tmp);   
    }
    long long ans = 0;     //  数值大小的判断要清楚,别不小心又WA。
    while(que.size() > 1){
        int a, b;
        a = que.top().value; que.pop();
        b = que.top().value; que.pop();
        tmp.value = a + b;
        que.push(tmp);  //将最优解再次放入队列中,寻找下一个最优解
        ans += tmp.value;
    }
    cout<<ans<<endl;
    return 0;
}

 


//经过que.push(tmp)之后的排列顺序为
//5
//8
//8
//没想到就用一个优先队列就将哈夫曼树给实现了
//这个从来没有想到过,牛人呀。
//但是我总觉得,这道题目并没有将哈夫曼树的
//作用以发挥到极点。还会有后戏的。
 
 
还有一个不用结构体来用优先队列的方法,但是效率上好像要差一些。
View Code
#include <iostream>  
#include <queue>  
using namespace std;  
int main()
{  
    int n;  
    priority_queue<int,vector<int>,greater<int> > qu;  //就是这句话了
    while(cin>>n)
    {  
        while(n--)
        {  
            int x;  
            cin>>x;  
            qu.push(x);  
        }  
        int a=0,b=0;  
        long long res=0;  
        while(qu.size()>1)
        {  
            a=qu.top();  
            qu.pop();  
            b=qu.top();  
            qu.pop();  
            res+=a+b;  
            qu.push(a+b) ;  
        }   
        cout<<res<<endl;   
    }  
    return 0;  
}   

 

 

posted on 2011-09-25 11:41  More study needed.  阅读(220)  评论(0编辑  收藏  举报

导航

书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!