STL之map——解决POJ 2503
Description
You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to
100,000 dictionary entries, followed by a blank line, followed by a message of
up to 100,000 words. Each dictionary entry is a line containing an English word,
followed by a space and a foreign language word. No foreign word appears more
than once in the dictionary. The message is a sequence of words in the foreign
language, one word on each line. Each word in the input is a sequence of at most
10 lowercase letters.
Output
Output is the message
translated to English, one word per line. Foreign words not in the dictionary
should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay
atcay
ittenkay
oopslay
Sample Output
cat
eh
loops
#include<iostream>
#include<map>
using namespace std;
int main()
{
string str1, str2, str;
map<string, string> m;
map<string, string>::iterator it;
while(1)
{
cin>>str1;
if(getchar()!=' ')
break;
cin>>str2;
m[str2] = str1;
}
do
{
it = m.find(str1);
if(it==m.end())
cout<<"eh"<<endl;
else
cout<<m[str1]<<endl;
}while(cin>>str1);
return 0;
}
posted on 2011-09-23 22:52 More study needed. 阅读(179) 评论(0) 编辑 收藏 举报