STL之map——解决POJ 2503
Description
You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to
100,000 dictionary entries, followed by a blank line, followed by a message of
up to 100,000 words. Each dictionary entry is a line containing an English word,
followed by a space and a foreign language word. No foreign word appears more
than once in the dictionary. The message is a sequence of words in the foreign
language, one word on each line. Each word in the input is a sequence of at most
10 lowercase letters.
Output
Output is the message
translated to English, one word per line. Foreign words not in the dictionary
should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay
atcay
ittenkay
oopslay
Sample Output
cat
eh
loops
#include<iostream>
#include<map>
using namespace std;
int main()
{
string str1, str2, str;
map<string, string> m;
map<string, string>::iterator it;
while(1)
{
cin>>str1;
if(getchar()!=' ')
break;
cin>>str2;
m[str2] = str1;
}
do
{
it = m.find(str1);
if(it==m.end())
cout<<"eh"<<endl;
else
cout<<m[str1]<<endl;
}while(cin>>str1);
return 0;
}
posted on 2011-09-23 22:52 More study needed. 阅读(179) 评论(0) 编辑 收藏 举报
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· 10年+ .NET Coder 心语 ── 封装的思维:从隐藏、稳定开始理解其本质意义
· 地球OL攻略 —— 某应届生求职总结
· 提示词工程——AI应用必不可少的技术
· Open-Sora 2.0 重磅开源!
· 周边上新:园子的第一款马克杯温暖上架