书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!

STL之stack——解决POJ 1028

 

Describution

Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.
The following commands need to be supported:
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.

VISIT:Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.

QUIT:Quit the browser.

Assume that the browser initially loads the web page at the URL http://www.acm.org/

Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

Sample Input

VISIT http://acm.ashland.edu/
VISIT http://acm.baylor.edu/acmicpc/
BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/
BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT
Sample Output
http://acm.ashland.edu/
http://acm.baylor.edu/acmicpc/
http://acm.ashland.edu/
http://www.acm.org/
Ignored
http://acm.ashland.edu/
http://www.ibm.com/
http://acm.ashland.edu/
http://www.acm.org/
http://acm.ashland.edu/
http://www.ibm.com/
Ignored
 
其实吧,要解决这道,并不难,但是要注意一点:
backward堆中要始终保持有原始的那个网页,
一旦将其pop()之后,就相当于关了浏览器,
这是错误的。

复制代码
View Code
#include<iostream>
#include<string>
#include<stack>
using namespace std;
#define ACM "http://www.acm.org/"
int main(){
    stack<string>Forward;
    stack<string>Backward;
    string str;
    Backward.push(ACM);
    while(cin>>str){
        if(str == "QUIT")break;
        if(str == "VISIT"){
            cin>>str;
            cout<<str<<endl;
            Backward.push(str);
            while(!Forward.empty())Forward.pop();
        }
        if(str == "BACK"){
            if(Backward.size()>1){
                Forward.push(Backward.top());
                Backward.pop();
                cout<<Backward.top()<<endl;
            }
            else{
                cout<<"Ignored"<<endl;
            }
        }
        if(str == "FORWARD"){
            if(!Forward.empty()){
                cout<<Forward.top()<<endl;
                Backward.push(Forward.top());
                Forward.pop();
            }
            else {
                cout<<"Ignored"<<endl;
            }
        }
    }
    return 0;
}
复制代码

 

 

posted on   More study needed.  阅读(214)  评论(0编辑  收藏  举报

编辑推荐:
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
阅读排行:
· 10年+ .NET Coder 心语 ── 封装的思维:从隐藏、稳定开始理解其本质意义
· 地球OL攻略 —— 某应届生求职总结
· 提示词工程——AI应用必不可少的技术
· Open-Sora 2.0 重磅开源!
· 周边上新:园子的第一款马克杯温暖上架
< 2011年9月 >
28 29 30 31 1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 1
2 3 4 5 6 7 8

导航

统计

书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!

点击右上角即可分享
微信分享提示