书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!

Kruskal算法解决POJ 1258

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
 
 
#include "iostream"
#include "algorithm"
using namespace std;
structline
{
	int begin;
	int end;
	int length;
};
line Num[10001];
int father[101], map[101][101], i, j, numofline, numofnode;
int find(int k)
{
	return father[k]==k?k:father[k]=find(father[k]);
}
int cmp(line a, line b)
{
	return a.length<b.length;
}
int kruskal()
{
	int minlen = 0, a, b;
	for(i=0; i<numofline; i++)
	{
		a = find(Num[i].begin);
		b = find(Num[i].end);
		if(a!=b)
		{
			father[a] = b;
			minlen += Num[i].length;
		}
	}
	return minlen;
}
void Init()
{
	int counter=0;
	for(i=1; i<=numofnode; i++)  //这两个数组要从1开始,在利于father数组的初始化,但同时要注意i<=numofnode,中的=号不要忘记了。
	{
		for(j=1; j<=numofnode; j++)  //注意这里是双重循环,所以Num结构体要开nodenum的平方倍。不然会出现Memory Limit Exceeded。
		{
			cin>>map[i][j];
			if(i<j)
			{
				Num[counter].begin = i;
				Num[counter].end = j;
                Num[counter++].length = map[i][j];
			}
		}
		father[i] = i;
		numofline = counter;  //初始化nomofline.
	}
	sort(Num, Num+counter, cmp);
}
int main()
{
	while(cin>>numofnode)
	{
		Init();
		cout<<kruskal()<<endl;
	}
}

posted on 2011-09-23 20:55  More study needed.  阅读(305)  评论(0编辑  收藏  举报

导航

书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!