书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!

Kruskal算法解决POJ 1251

 

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

复制代码
View Code
#include "iostream"
#include "algorithm"
using namespace std;
struct line{
    int begin, end, len;
};
line num[100];
int amount, sum_line;
int i, j;
int father[100];
int minlen;
int find(int k){
    return father[k]==k?k:father[k]=find(father[k]);
}
int cmp(line a, line b){
    return a.len<b.len;
}
int kruskal(){ 
    minlen = 0;
    int a, b;
    for(i=0; i<sum_line; i++){   //以边为核心来遍历,因为每条边有两个点,起点和终点。这个正是Kruskal的特色
        a = find(num[i].begin);
        b = find(num[i].end);
        if(a!=b){
            father[a] = b;  //更新父结点
            minlen += num[i].len;
        }
    }
    return minlen;
}
void init()
{
    sum_line = 0;
    char start, tmpend;
    int tmpline, tmplen;
    int a, b;
    for(i=0; i<amount; i++){
        father[i] = i;
    }
    for(i=0; i<amount-1; i++){
        cin>>start;
        cin>>tmpline;
        a = start-'A';
        for(j=0; j<tmpline; j++){
            cin>>tmpend;
            cin>>tmplen;
            b = tmpend-'A';
            num[sum_line].begin = a;
            num[sum_line].end = b;
            num[sum_line++].len = tmplen;
        }
    }
    sort(num, num+sum_line, cmp);
}
int main()
{
    while(cin>>amount && amount)
    {
        init();
        cout<<kruskal()<<endl;
    }
    return 0;
}
复制代码

 

 

posted on   More study needed.  阅读(308)  评论(0编辑  收藏  举报

编辑推荐:
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
阅读排行:
· 10年+ .NET Coder 心语 ── 封装的思维:从隐藏、稳定开始理解其本质意义
· 地球OL攻略 —— 某应届生求职总结
· 提示词工程——AI应用必不可少的技术
· Open-Sora 2.0 重磅开源!
· 周边上新:园子的第一款马克杯温暖上架
< 2011年9月 >
28 29 30 31 1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 1
2 3 4 5 6 7 8

导航

统计

书山有径勤为路>>>>>>>>

<<<<<<<<学海无涯苦作舟!

点击右上角即可分享
微信分享提示