You are my brother NBUT - 1218

问题描述

Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is his elder, younger or brother.

输入

There are multiple test cases.
For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered 2.
Proceed to the end of file.

输出

For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly one line.

样例输入
5
1 3
2 4
3 5
4 6
5 6
6
1 3
2 4
3 5
4 6
5 7
6 7
样例输出
You are my elder
You are my brother
提示

来源
辽宁省赛2010

#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<cstdio>
#include<sstream>
#include<numeric>//STL数值算法头文件
#include<stdlib.h>
#include <ctype.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板类头文件
using namespace std;

typedef long long ll;
const int maxn=11000;
const int INF=0x3f3f3f3f;

int a,b,n;
int fa[maxn];

int main()
{
    while(cin>>n)
    {
        int x1,x2,cot1,cot2;
        for(int i=0; i<maxn; i++)
            fa[i]=i;
        while(n--)
        {
            scanf("%d %d",&a,&b);
            fa[a]=b;
        }
        x1=1;
        cot1=0;
        while(fa[x1]!=x1)
        {
            x1=fa[x1];
            cot1++;
        }
        x2=2;
        cot2=0;
        while(fa[x2]!=x2)
        {
            x2=fa[x2];
            cot2++;
        }
        if(cot1>cot2)
            printf("You are my elder\n");
        else if(cot1<cot2)
            printf("You are my younger\n");
        else
            printf("You are my brother\n");
    }
    return 0;
}
posted @ 2017-04-10 16:30  xushukui  阅读(130)  评论(0编辑  收藏  举报