poj1005

I Think I Need a Houseboat
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 110117 Accepted: 47728
Description
Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)

 

Input
The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.
Output
For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”
Sample Input
2
1.0 1.0
25.0 0.0
Sample Output
Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

由于随着年份增长,面积增量固定,半圆区域半径变化递减,在超过一定值时,变化可以小到忽略不计看作定值减少计算和空间占用。

//Memory time
//3196K . 157MS
import java.util.*;
public class Main 
{
    public static double getDis( double x, double y)
    {
        return Math.sqrt(Math.pow(x,2)+ Math.pow(y,2));
    }
    
    public statci double getNowLoss(int year)
    {
        if(year < 100000)
        {
            if(dis_year[year]==0)
                dis_year[year] = Math.sqrt(50*year*2/Math.PI);
            return dis_year[year];
        }else 
        {
          return Math.sqrt(50*year*2/Math.PI);
        }
    }
    
    public static final double[] dis_year = new double[100004];
    
    public static void main(String[] args)
    {
        Scanner scan = new Scanner(System.in);
        int n = scan.nextInt();
        for(int i=0;i<n;i++)
        {
            double x = scan.nextDouble();
            double y = scan.nextDouble();
            int year =1;
            while(true)
            {
                if(getDis(x,y)<=getNowLoss(year))
                {
                    System.out.println("Property"+(i+1)+":This property will begin eroding in year"+year+".")
                    break;
                }
                year++;
            }
            
        }
        System.out.println("END OF OUTPUT");
    
    }
}

 

posted @ 2018-05-30 09:22  大卫·肖  阅读(110)  评论(0编辑  收藏  举报