还是A+B

Description

读入两个小于10000的正整数A和B,计算A+B。需要注意的是:如果A和B的末尾K(不超过8)位数字相同,请直接输出-1。

Input

测试输入包含若干测试用例,每个测试用例占一行,格式为"A B K",相邻两数字有一个空格间隔。当A和B同时为0时输入结束,相应的结果不要输出。

Output

对每个测试用例输出1行,即A+B的值或者是-1。

-------------------------------------------------------------------------------------------------------------------

Sample Input

1 2 1
11 21 1
108 8 2
36 64 3
0 0 1
-------------------------------------------------------------------------------------------------------------------

Sample Output

3
-1
-1
100
-------------------------------------------------------------------------------------------------------------------
代码如下:
#include<iostream>
#include<cstdio>

using namespace std;

int panduan(int x,int y,int z)
{
	int sum =0;
	int k=z;
	while(z--)
	{
		int a=x%10;
		int b=y%10;
		x = x/10;
		y = y/10;
		if(a==b) sum++;
		if(z==0 && sum==k) return 1;
		if(z==0 && sum!=k) return 0;  
	}
        return 1;
}
int main()
{
	int x,y,z;
	while(scanf("%d%d%d",&x,&y,&z)!=EOF)
	{
		if(x==y && x==0) break;
		if(panduan(x,y,z)==1){
			printf("-1\n");
		}else{
			printf("%d\n",x+y);
		}
	}
	return 0;
}
-------------------------------------------------------------------------------------------------------------------
posted @ 2017-07-11 08:34  让你一生残梦  阅读(195)  评论(0编辑  收藏  举报