Safecracker

Description

The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary.

v - w^2 + x^3 - y^4 + z^5 = target

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."

Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations.

************************************************************************

Input

Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input.

************************************************************************

Output

For each line output the Klein combination, break ties with lexicographic order, or "no solution" if there is no correct combination. Use the exact format shown below.

************************************************************************

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END
************************************************************************

Sample Output

LKEBA
YOXUZ
GHOST
no solution
************************************************************************
  这题直接就是枚举一下,因为他说一定是五个大写字母,所以就是5层for循环,关键就是剪枝的问题。
************************************************************************
代码如下:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

char a[13];
int b[13];

bool cmp(char n,char m)
{
	return n>m;
}

int main()
{
	int n;
	char h[4] = {"END"};	
	char ch;	
	int i=0;
	while(scanf("%d %s",&n,&a)!=EOF)
	{
		if(n==0 && strcmp(a,h)==0) 
		    break;
		int len = strlen(a);
		sort(a,a+len,cmp);
                //排序完了,再去存,或者在5层循环里面,用5个变量。
		for(int i=0;i<len;i++)
		{
			b[i]=a[i]-'A'+1;
		}
		int o = 0;
		for(int i=0;i<len && o==0;i++)
		{
			for(int j=0; j<len && o==0;j++)
			{ 
				if(i==j) 
				     continue;
				for(int t=0;t<len  && o==0;t++)
				{
					if(t==j || t==i) 
					    continue;
					for(int q=0;q<len && o==0;q++)
					{
						if( t==q || j==q || q==i) 
						   continue;
						for(int m=0;m<len && o==0;m++)
						{
							if(m==t || m==i || m==q || m==j) 
							   continue;
							if(b[i] - b[j]*b[j] + b[t]*b[t]*b[t] - b[q]*b[q]*b[q]*b[q] + b[m]*b[m]*b[m]*b[m]*b[m] == n){
								printf("%c%c%c%c%c\n",b[i]+'A'-1,b[j]+'A'-1,b[t]+'A'-1,b[q]+'A'-1,b[m]+'A'-1);
								o=1;
							}
						}
					}
				}
			}
		}
		if(o==0) printf("no solution\n");
	}
	return 0;
}


************************************************************************

posted @ 2017-07-14 17:27  让你一生残梦  阅读(321)  评论(0编辑  收藏  举报