Milking Cows(线段区间问题)

Description

Three farmers rise at 5 am each morning and head for the barn to milk three cows. The first farmer begins milking his cow at time 300 (measured in seconds after 5 am) and ends at time 1000. The second farmer begins at time 700 and ends at time 1200. The third farmer begins at time 1500 and ends at time 2100. The longest continuous time during which at least one farmer was milking a cow was 900 seconds (from 300 to 1200). The longest time no milking was done, between the beginning and the ending of all milking, was 300 seconds (1500 minus 1200).

Your job is to write a program that will examine a list of beginning and ending times for N (1 <= N <= 5000) farmers milking N cows and compute (in seconds):

The longest time interval at least one cow was milked.The longest time interval (after milking starts) during which no cows were being milked.

Input

INPUT FORMAT For Each Test Data

Line 1: The single integer
Lines 2..N+1: Two non-negative integers less than 1000000, the starting and ending time in seconds after 0500

 

Output

OUTPUT FORMAT

A single line with two integers that represent the longest continuous time of milking and the longest idle time.

Sample Input

3
300 1000
700 1200
1500 2100

Sample Output

900 300

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

struct node
{
    int n,m;
} a[10000];

bool cmp(node n,node m)
{
    return n.n<m.n;
}

int main()
{
    int m;
    while(scanf("%d",&m)!=EOF)
    {
        memset(a,0,sizeof(a));
        for(int i=0; i<m; i++)
            scanf("%d%d",&a[i].n,&a[i].m);
        sort(a,a+m,cmp);
        long long sum = a[0].n,sum1 = a[0].m;
        long long list_max = sum1 - sum;
        long long list_min = 0;
        for(int i=1; i<m; i++)
        {
            if(sum1 < a[i].n)      ///不存在交点问题,意思就是要跳点
            {
                long long  ans = sum1 - sum;
                if(list_max<ans) list_max = ans;
                if(list_min < a[i].n-sum1) list_min = a[i].n-sum1;
                sum = a[i].n;
                sum1 = a[i].m;
            }
            else          ///就是存在相交部分,所以直接将后面的sum1,变为a[i].m,此时sum到sum1,就表示两个区间的总长度
            {
                if(sum1 <a[i].m)
                    sum1 = a[i].m;
            }
        }
        printf("%lld %lld\n",list_max,list_min);
    }
    return 0;
}
posted @ 2017-10-14 17:49  让你一生残梦  阅读(177)  评论(0编辑  收藏  举报