Max Sum

                                                                            Max Sum

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

代码如下:
#include <stdio.h>
#include <string.h>

int dp[50005];

int main()
{
    int T;
    scanf("%d",&T);
    for(int u=1; u<=T; u++)
    {
        int m;
        scanf("%d",&m);
        for(int i=1; i<=m; i++)
            scanf("%d",&dp[i]);
        int sum =-1000,ans =0,si = 1,ei,ej;
        for(int i=1; i<=m; i++)
        {
            ans += dp[i];
            if(ans>sum)
            {
                sum = ans;
                ei  = si;
                ej = i;
            }
            if(ans <0)
            {
                ans = 0;
                si = i+1;
            }
        }
        printf("Case %d:\n",u);
        printf("%d %d %d\n",sum,ei,ej);
        if(u!=T) printf("\n");
    }
    return 0;
}
posted @ 2017-10-27 18:21  让你一生残梦  阅读(189)  评论(1编辑  收藏  举报