这次作业属于那个课程 C语言程序设计
这个作业要求在哪里 https://edu.cnblogs.com/campus/zswxy/software-engineering-class1-2018/homework/3202
我在这个课程的目标是 掌握编译预处理的概念
这个作业在那个具体方面帮助我实现目标 处理方面
参考文献 C语言程序设计

 

一,单选题

 

二,汉诺塔问题

汉诺塔是一个源于印度古老传说的益智玩具。据说大梵天创造世界的时候做了三根金刚石柱子,在一根柱子上从下往上按照大小顺序摞着64片黄金圆盘,大梵天命令僧侣把圆盘移到另一根柱子上,并且规定:在小圆盘上不能放大圆盘,每次只能移动一个圆盘。当所有圆盘都移到另一根柱子上时,世界就会毁灭。

题图1.jpg

请编写程序,输入汉诺塔圆片的数量,输出移动汉诺塔的步骤。

输入格式

圆盘数 起始柱 目的柱 过度柱

输出格式

移动汉诺塔的步骤
每行显示一步操作,具体格式为:
盘片号: 起始柱 -> 目的柱
其中盘片号从 1 开始由小到大顺序编号。

输入样例

3
a c b

输出样例

1: a -> c
2: a -> b
1: c -> b
3: a -> c
1: b -> a
2: b -> c
1: a -> c

1.实验代码
#include<stdio.h>
void hanio(int n,char a,char b,char c);
int main(void)
{
    int n;
    char a,b,c;
    scanf("%d\n",&n);
    scanf("%c %c %c",&a,&b,&c);
    hanio(n,a,b,c);
    return 0;
}
void hanio(int n,char a,char b,char c)
{
    if(n==1)
    printf("%d: %c -> %c\n",n,a,b);
    else{
        hanio(n-1,a,c,b);
        printf("%d: %c -> %c\n",n,a,b);
        hanio(n-1,c,b,a);
    }
}

2.设计思路

三,运行结果截图

四,遇到的问题及解决方法


以下题目由于实在是不太会所以借鉴的其他人的博客
6-1 计算最长的字符串长度
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:
int max_len( char *s[], int n );

其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。

裁判测试程序样例:

复制代码
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAXN 10
#define MAXS 20

int max_len( char *s[], int n );

int main()
{
    int i, n;
    char *string[MAXN] = {NULL};

    scanf("%d", &n);
    for(i = 0; i < n; i++) {
        string[i] = (char *)malloc(sizeof(char)*MAXS);
        scanf("%s", string[i]);
    }
    printf("%d\n", max_len(string, n));

    return 0;
}

/* 你的代码将被嵌在这里 */
复制代码

输入样例:

4
blue
yellow
red
green

输出样例:

6

实验代码:

复制代码
int max_len( char *s[], int n )
{
    int m=0;
    for(int i=0;i<n;i++)
    {
        int t=strlen(s[i]);
        if(m < t)
        {
            m=t;
        }
    }
    return m;
}
复制代码

设计思路:

 


 运行结果图:


 


6-2 统计专业人数 (15 分)
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:



struct ListNode {
    char code[8];
    struct ListNode *next;
};

这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。


函数接口定义:


int countcs( struct ListNode *head );

其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。


裁判测试程序样例:


#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct ListNode {
    char code[8];
    struct ListNode *next;
};

struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );

int main()
{
    struct ListNode  *head;

    head = createlist();
    printf("%d\n", countcs(head));
    
    return 0;
}

/* 你的代码将被嵌在这里 */
输入样例:


1021202
2022310
8102134
1030912
3110203
4021205
#

输出样例:


3

(1)实验代码


int countcs( struct ListNode *head )
{
    struct ListNode *p=head;
    int count=0;
    for(p=head;p!=NULL;p=p->next)
    {
        if(p->code[1]=='0'&&p->code[2]=='2')
        {
            count++;
        }
    }
    return count;
}

(2)设计思路

(3)本题遇到的问题及解决方法:无。
(4)运行截图

 
posted on 2019-05-11 11:57  苦歌  阅读(306)  评论(2编辑  收藏  举报