hdu 1085 Holding Bin-Laden Captive!

Description

We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ” 



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem? 
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.” 
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush! 

Input

Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed. 

Output

Output the minimum positive value that one cannot pay with given coins, one line for one case. 

Sample Input

1 1 3
0 0 0

Sample Output

4

解析:
母函数的变形题,还是正常模拟两个式子相乘,然后循环找没有系数的那个值,
注意:循环到 sum+1 (因为会出现 2 0 0 情况 这时的值为 3
#include <iostream>
#include <cstring>
using namespace std;

int main()
{
    int num_1,num_2,num_5,sum;
    int c1[8005],c2[8005];
    while(cin>>num_1>>num_2>>num_5)
    {
        if(num_1==0&&num_2==0&&num_5==0)
        break;
        sum=(num_1+num_2*2+num_5*5);
        for(int i=0;i<=num_1;i++)
        {
            c1[i]=1;
            c2[i]=0;
        }
        for(int i=0;i<=num_1;i++)
         for(int j=0,ans=0;j<=num_2;j++,ans+=2)
         {
             c2[i+ans]+=c1[i];
         }
        memcpy(c1,c2,sizeof(c2));
        memset(c2,0,sizeof(c2));
       for(int i=0;i<=num_1+num_2*2;i++)
       {
           for(int j=0,ans=0;j<=num_5;j++,ans+=5)
           c2[i+ans]+=c1[i];
       }
        memcpy(c1,c2,sizeof(c2));
        memset(c2,0,sizeof(c2));
        for(int i=1;i<=sum+1;i++)
        {
            if(c1[i]==0)
            {
                cout<<i<<endl;break;
            }
        }
    }
    return 0;
}

 

posted @ 2016-10-30 20:59  邻家那小孩儿  阅读(200)  评论(0编辑  收藏  举报