hdu 1398 Square Coins

Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins, 
one 4-credit coin and six 1-credit coins, 
two 4-credit coins and two 1-credit coins, and 
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland. 

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300. 

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 

Sample Input

2
10
30
0

Sample Output

1
4
27


解析:
这是整数拆分的变形题,提供的整数变成平方项

#include <iostream>
#include <cstring>
using namespace std;

int main()
{
    int n;
    int c1[305],c2[305];
    while(cin>>n&&n)
    {
        for(int i=0;i<=n;i++)
        {
            c1[i]=1;
            c2[i]=0;
        }
        for(int i=2;i<=17;i++)
        {
            for(int j=0;j<=n;j++)
             for(int k=0;k+j<=n;k+=i*i)
              c2[k+j]+=c1[j];
            memcpy(c1,c2,sizeof(c2));
            memset(c2,0,sizeof(c2));
        }
        cout<<c1[n]<<endl;
    }
    return 0;
}

 

posted @ 2016-10-30 20:11  邻家那小孩儿  阅读(121)  评论(0编辑  收藏  举报