poj 3278 Catch That Cow bfs

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

//简单bfs
#include <cstdio>
#include <algorithm>
#include <iostream>
#include <queue>
#include <cstring>

using namespace std;
int visit[100005];
int n,k;

struct node
{
    int x,step;
};

void bfs()
{
    node st,ed;
    queue <node> q;
    st.x=n;
    st.step=0;
    memset(visit,0,sizeof(visit));
    visit[n]=1;
    q.push(st);
    while(!q.empty())
    {
        st=q.front();
        q.pop();
        if(st.x==k)
        {
            cout<<st.step<<endl;
            return ;
        }
        if(st.x+1<=100000&&visit[st.x+1]==0)
        {
            visit[st.x+1]=1;
            ed.x=st.x+1;
            ed.step=st.step+1;
            q.push(ed);
        }
        if(st.x-1>=0&&visit[st.x-1]==0)
        {
            visit[st.x-1]=1;
            ed.step=st.step+1;
            ed.x=st.x-1;
            q.push(ed);
        }
        if(2*st.x<=100000&&visit[2*st.x]==0)
        {
            visit[2*st.x]=1;
            ed.step=st.step+1;
            ed.x=st.x*2;
            q.push(ed);
        }
    }
}

int main()
{
    while(cin>>n>>k)
    {
        bfs();
    }
    return 0;
}

 

posted @ 2016-08-12 15:28  邻家那小孩儿  阅读(163)  评论(0编辑  收藏  举报