poj 3524 Charm Bracelet(01背包)

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

//依然是01背包基础题

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int value[3500],volume[3500],dp[12885];

int main()
{
    int n,v;
    while(cin>>n>>v)
    {
        for(int i=1;i<=n;i++)
        cin>>volume[i]>>value[i];
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
         for(int j=v;j>=volume[i];j--)
          dp[j]=max(dp[j],dp[j-volume[i]]+value[i]);
        cout<<dp[v]<<endl;
    }
    return 0;
}

 

posted @ 2016-06-03 10:54  邻家那小孩儿  阅读(114)  评论(0编辑  收藏  举报