hdu 1211 RSA

Problem Description
RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:

> choose two large prime integer p, q
> calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
> choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
> calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key

You can encrypt data with this method :

C = E(m) = me mod n

When you want to decrypt data, use this method :

M = D(c) = cd mod n

Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.

Now given p, q, e and some cryptograph, your task is to "translate" the cryptograph into plain text.
 

 

Input
Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks. 
 

 

Output
For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.
 

 

Sample Input
101 103 7 11 7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239
 

 

Sample Output
I-LOVE-ACM.

 

//题目大意
//解密方法:(d*e)%fn==1 解出d; m=(c^d)%n; 将m以char 类型输出
     
#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;


int main()
{
    int p,q,e,t,n,fn,d;
    while(cin>>p>>q>>e>>t)
    {
        n=q*p;
        fn=(q-1)*(p-1);
        d=fn/e+1;
        while((d*e)%fn!=1) d++;
        for(int i=1;i<=t;i++)
        {
            int c,m;
            cin>>c;
            m=1;
            for(int j=1;j<=d;j++)
            {
                m=m*c;
                m=m%n;
            }
            cout<<(char)m;
        }
        cout<<endl;
    }
    return 0;
}

 

posted @ 2016-05-14 22:58  邻家那小孩儿  阅读(156)  评论(0编辑  收藏  举报