hdu 2111 Saving HDU

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

 

Sample Output
13.333 31.500
 
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;

struct node
{
    int j,v;
    double bi;
} data[105];

bool cmp(const node &a,const node &b)
{
    if(a.j>b.j)
    return true;
    else return false;
}

int main()
{
    int v,n;
    double ans;
    while(cin>>v&&v)
    {
        cin>>n;
        ans=0;
        for(int i=0;i<n;i++)
        {
            cin>>data[i].j>>data[i].v;
            data[i].bi=(double)data[i].j/(double)data[i].v*1.0;
        }
        sort(data,data+n,cmp);
        for(int i=0;i<n;i++)
        {
            if(v>=data[i].v)
            {
                v=v-data[i].v;
                ans+=data[i].j*data[i].v;
            }
            else
            {
                ans+=v*data[i].j;
                break;
            }
        }
        printf("%.0lf\n",ans);
    }
    return 0;
}

 

posted @ 2016-05-04 00:26  邻家那小孩儿  阅读(122)  评论(0编辑  收藏  举报