hdu 1789 Doing Homework again

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 
Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 
Output
For each test case, you should output the smallest total reduced score, one line per test case.
 
Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 
Sample Output
0 3 5
 
//唉,感觉自己好笨呀,不看题解根本想不到。。
//决定最近好好刷刷贪心,好好理解理解
 
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int ans;

struct node
{
    int time;
    int fen;
} work[1005];

bool cmp(const node &a,const node &b)
{
    if(a.fen>b.fen)
    return true;
    else if(a.fen==b.fen)
    {
        if(a.time<b.time)
        return true;
        else
        return false;
    }
    else return false;

}

int main()
{
    int t,n;
    int ss[1005];
    cin>>t;
    while(t--)
    {
        memset(ss,0,sizeof(ss));
        ans=0;
        cin>>n;
        for(int i=0;i<n;i++)
        cin>>work[i].time;
        for(int i=0;i<n;i++)
        cin>>work[i].fen;
        sort(work,work+n,cmp);
        //for(int i=0;i<n;i++)
        //cout<<work[i].time<<"  "<<work[i].fen<<endl;
        for(int i=0;i<n;i++)
        {
            int j=work[i].time;
            while(j--)
            {
                if(ss[j]==0)
                {
                    ss[j]=1;
                    break;
                }
            }
            if(ss[j]!=1)
            ans+=work[i].fen;
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

 
posted @ 2016-04-03 13:37  邻家那小孩儿  阅读(139)  评论(0编辑  收藏  举报