poj 1163 The Triangle

Description

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

//做的第一道DP题,加油

 //思路就是建立一个数组,由下向上动态规划,保存页子节点到当前节点的最大值

#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstdio>
using namespace std;

int main()
{
    int dp[102][102];
    int n;
    while(cin>>n)
    {
        for(int i=1;i<=n;i++)
         for(int j=0;j<i;j++)
          cin>>dp[i][j];
        for(int i=n-1;i>=1;i--)
         for(int j=0;j<i;j++)
          dp[i][j]+= max(dp[i+1][j],dp[i+1][j+1]);
        cout<<dp[1][0]<<endl;
    }
    return 0;
}

 

posted @ 2016-04-02 19:56  邻家那小孩儿  阅读(113)  评论(0编辑  收藏  举报