HDU1711:Number Sequence

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5 1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 
Sample Output
6
-1
 
 
 
//low方法应该是一点一点的找,但是,运用KMP算法会变牛逼。。(KMP竟然还可以用到数组中!!(⊙o⊙)
//这题很有趣,让我知道算法更重要的是思想,不要有局限自己思维
 
 
#include <iostream>
#include <cstdio>

using namespace std;
int data1[1000003],data2[1000003];
int nex[1000003],n,m;

void getnext()
{
    int i=0,j=-1;
    nex[0]=-1;
    while(i<m)
    {
        if(j==-1||data2[i]==data2[j])
        {
            i++;j++;
            if(data2[i]==data2[j])
            nex[i]=nex[j];
            else
            nex[i]=j;
        }
        else
        j=nex[j];
    }
}

int kmp()
{
    int i=0,j=0;
    getnext();
    while(i<n)
    {
        if(j==-1||data1[i]==data2[j])
        {
            i++;j++;
        }
        else
        {
            j=nex[j];// j=nex[i]这里又记错了。。。。
        }
        if(j==m)
        return i-m+1;
    }
    return -1;
}

int main()
{
    int l;
    cin>>l;
    while(l--)
    {
        cin>>n>>m;
        for(int i=0;i<n;i++)
        scanf("%d",&data1[i]);
        for(int i=0;i<m;i++)
        scanf("%d",&data2[i]);
        getnext();
        int ans=kmp();
        cout<<ans<<endl;

    }
    return 0;
}

 

 
posted @ 2016-03-20 16:34  邻家那小孩儿  阅读(167)  评论(0编辑  收藏  举报