hdu 3555 Bomb(数位DP,4级)

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 4443    Accepted Submission(s): 1538


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
3 1 50 500
 

Sample Output
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

Source
 

Recommend
zhouzeyong

很水的数位DP

#include<cstdio>
#include<cstring>
#include<iostream>
#define FOR(i,a,b) for(int i=a;i<=b;++i)
#define clr(f,z) memset(f,z,sizeof(f))
#define LL __int64
using namespace std;
LL dp[40][10][2];//位数,最后一个数,是否有49
int bit[40],pos;
LL DP(int pp,int ee,bool has,bool big)
{
  if(pp==0)return has;
  if(big&&dp[pp][ee][has]!=-1)return dp[pp][ee][has];
  int kn=big?9:bit[pp];
  LL ret=0;
  FOR(i,0,kn)
  {
    ret+=DP(pp-1,i,has||(ee==4&&i==9),big||(i!=kn));
  }
  if(big)dp[pp][ee][has]=ret;
  return ret;
}
LL get(LL x)
{ pos=0;
  while(x)
  {
    bit[++pos]=x%10;x/=10;
  }
  clr(dp,-1);
  return DP(pos,0,0,0);
}
int main()
{
  int cas;
  while(cin>>cas)
  {
    while(cas--)
    {
      LL n;
      cin>>n;
      cout<<get(n)<<endl;
    }
  }
}


 
posted @ 2013-08-19 11:41  剑不飞  阅读(162)  评论(0编辑  收藏  举报