ZOJ 2412 Farm Irrigation(DFS+状态压缩)

Farm Irrigation

Time Limit: 2 Seconds Memory Limit: 65536 KB

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE
then the water pipes are distributed like

Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output
2
3

思路:用二进制状态压缩来表示上述状态,然后深搜就可以了。

   A-K这11种状态可以用3,6,9,12,10,5,7,11,13,14,15来表示然后判断符合条件的搜一搜就行了。

#include<iostream>
#include<cstring>
using namespace std;
const int mm=110;
const int dx[]={0,-1,0,1};//左上右下的顺序和状态压缩的顺序要一样
const int dy[]={-1,0,1,0};
const int dd[]={3,6,9,12,10,5,7,11,13,14,15};
int g[mm][mm];
char s;
int n,m;
void dfs(int x,int y)
{
  int tx,ty;
  for(int i=0;i<4;i++)
  {
    tx=x+dx[i];ty=y+dy[i];
    if(tx<0||tx>=n||ty<0||ty>=m)continue;
    int z=g[x][y]&g[tx][ty];
    int k=g[x][y];
    g[x][y]=0;
    if((k&(1<<i))&&(g[tx][ty]&(1<<((i+2)%4))))
      dfs(tx,ty);
    g[x][y]=k;
  }
  g[x][y]=0;
}
int main()
{
  while(cin>>n>>m)
  {
    if(n==-1&&m==-1)break;
    for(int i=0;i<n;i++)
      for(int j=0;j<m;j++)
    {
      cin>>s;g[i][j]=dd[s-'A'];
    }
    int ans=0;
    for(int i=0;i<n;i++)
      for(int j=0;j<m;j++)
      if(g[i][j])
      dfs(i,j),ans++;
    cout<<ans<<"\n";
  }
}





posted @ 2013-02-04 16:13  剑不飞  阅读(128)  评论(0编辑  收藏  举报