hdu 1114 Piggy-Bank(DP背包)

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6244    Accepted Submission(s): 3137


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!


 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.


 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".


 

Sample Input
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4


 

Sample Output
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.


 

Source


 

Recommend
Eddy

 

思路:简单的背包问题,f[x][y]表示前x个不同硬币能达到重量y的最小值。

        原先还以为是多重背包,还用2进制优化140MS过了,后来发现2了。

        只是个普通背包就行了,改了62MS过了。貌似也没差太多。2进制优化真的很强大、

一次AC代码:

#include<iostream>
#include<cstring>
using namespace std;
const int mm=100009;
const int oo=2e9;
int f[mm];
int cas,n;
int main()
{
  while(cin>>cas)
  {
    while(cas--)
    {
      f[0]=0;
      int a,b,w;
      cin>>a>>b;w=b-a;
      for(int i=1;i<=w;i++)f[i]=oo;
      cin>>n;
      while(n--)
      {
        cin>>a>>b;
        int z=w/b;
        for(int k=1;k<=z;k*=2)
        {
          for(int j=0;j<=w-k*b;j++)
          {
          f[j+k*b]=f[j+k*b]<f[j]+k*a?f[j+k*b]:f[j]+k*a;
          }
          z-=k;
        }
        if(z)
        {
          for(int j=0;j<=w-z*b;j++)
          {
          f[j+z*b]=f[j+z*b]<f[j]+z*a?f[j+z*b]:f[j]+z*a;
          }
        }
      }
      if(f[w]==oo)cout<<"This is impossible.\n";
      else cout<<"The minimum amount of money in the piggy-bank is "<<f[w]<<".\n";

    }
  }
}


二次AC代码:

#include<iostream>
#include<cstring>
using namespace std;
const int mm=100009;
const int oo=2e9;
int f[mm];
int cas,n;
int main()
{
  while(cin>>cas)
  {
    while(cas--)
    {
      f[0]=0;
      int a,b,w;
      cin>>a>>b;w=b-a;
      for(int i=1;i<=w;i++)f[i]=oo;
      cin>>n;
      while(n--)
      {
        cin>>a>>b;
        for(int j=0;j<=w-b;j++)
          f[j+b]=f[j+b]<f[j]+a?f[j+b]:f[j]+a;
        /*int z=w/b;
        for(int k=1;k<=z;k*=2)
        {
          for(int j=0;j<=w-k*b;j++)
          {
          f[j+k*b]=f[j+k*b]<f[j]+k*a?f[j+k*b]:f[j]+k*a;
          }
          z-=k;
        }
        if(z)
        {
          for(int j=0;j<=w-z*b;j++)
          {
          f[j+z*b]=f[j+z*b]<f[j]+z*a?f[j+z*b]:f[j]+z*a;
          }
        }*/
      }
      if(f[w]==oo)cout<<"This is impossible.\n";
      else cout<<"The minimum amount of money in the piggy-bank is "<<f[w]<<".\n";

    }
  }
}


 

 

posted @ 2013-01-24 12:25  剑不飞  阅读(139)  评论(0编辑  收藏  举报