hdu 1069 Monkey and Banana(dp)

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4637    Accepted Submission(s): 2388


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.


 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.


 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".


 

Sample Input
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0


 

Sample Output
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342


 

Source


 

Recommend
JGShining

 

思路:dp[i]=E(dp[i-1])+h[i];dp[i]以第i个物体的地面为底所能达到的最大高度.那么可以先把所有的物体的按不同地面构造,一个长方体最多3个不同的面。以这些面为底面从小到  大排序,然后依次检查i物体为底所能得到的最大高度。即可求得答案

具体看代码。

失误点:没从0开始,WA了依次,编程不认真WA一次

 

#include<iostream>
#include<algorithm>
using namespace std;
class node
{
  public:
  int area;
  int x,y,h;
}*s;
int n;
bool cmp(node a,node b)
{
  return a.area<b.area;
}
int main()
{ int a,b,c;int cas=0;
  while(cin>>n&&n)
  { s=new node[3*n+5];
    for(int i=0;i<n;i++)
    {
      cin>>a>>b>>c;
      s[3*i].x=a;
      s[3*i].y=b;
      s[3*i].h=c;
      s[3*i].area=a*b;
      s[3*i+1].x=a;
      s[3*i+1].y=c;
      s[3*i+1].h=b;
      s[3*i+1].area=a*c;
      s[3*i+2].x=c;
      s[3*i+2].y=b;
      s[3*i+2].h=a;
      s[3*i+2].area=c*b;
    }
    sort(s,s+3*n,cmp);
    int hh=0;bool find=0;int ans=0;
    for(int i=0;i<3*n;i++)
    { find=0;hh=0;
      for(int j=0;j<=i-1;j++)
      {
        if((s[i].x>s[j].x&&s[i].y>s[j].y)||(s[i].y>s[j].x&&s[i].x>s[j].y))
        {
          if(hh<s[j].h)hh=s[j].h;
          find=1;
        }
      }
      if(find)s[i].h+=hh;
      if(s[i].h>ans)ans=s[i].h;
    }
    cout<<"Case "<<++cas<<": maximum height = "<<ans<<"\n";
  }
}


 

 

 

posted @ 2013-01-08 15:19  剑不飞  阅读(142)  评论(0编辑  收藏  举报