hdu 1011 Starship Troopers(树形DP)

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6276    Accepted Submission(s): 1692


Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.

Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

Sample Input
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1

Sample Output
50 7

Author
XU, Chuan

Source

Recommend
JGShining
 
思路:从根开始,假设已知子节点的最优解,那么父节点的最优解就是就等于子节点的最优解并上父节点即可。
         也就是设两个二维数组f[节点][还剩下的兵力,也就是战士],dp[][];f表示不包括父节点的最优,dp表示包括父节点的最优。
         那么dp【u】【j】=f【u】【j-所需要出战的数目】;f[u][j]=max(f[u][j],f[u]【j-可用兵力】+dp[子节点]【可用兵力】)
失误点:
      给的边是双向的的,应该两边添加,WA 了几次
 
#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
const int mm=104;
class node
{
  public:
  int bug,brain;
  vector<int>link;
}room[mm];
int n,m;
int dp[mm][mm],f[mm][mm];
bool vis[mm];
void dfs(int x)
{
  vector<int>::iterator it;
  int kill_bug;
  vis[x]=1;
  for(it=room[x].link.begin();it!=room[x].link.end();it++)
  { if(!vis[*it])
    {
      dfs(*it);
      for(int k=m;k>=1;k--)///troopers
      for(int j=1;j<=k;j++)///
      f[x][k]=max(f[x][k],f[x][k-j]+dp[*it][j]);///不包括父节点的最优解
    }
  }
  kill_bug=(room[x].bug+19)/20;
    //if(room[*it].bug%20)kill_bug++;
    for(int j=kill_bug;j<=m;j++)///包括父节点的最优解
    dp[x][j]=f[x][j-kill_bug]+room[x].brain;
}
int main()
{
  while(cin>>n>>m)
  {
    if(n==-1&&m==-1)break;
    for(int i=1;i<=n;i++)
    {cin>>room[i].bug>>room[i].brain;room[i].link.clear();}
    for(int i=1;i<=n-1;i++)
    {
      int a,b;cin>>a>>b;room[a].link.push_back(b);room[b].link.push_back(a);
    }
    memset(vis,0,sizeof(vis));
    memset(f,0,sizeof(f));
    memset(dp,0,sizeof(dp));
    if(m==0)
    {
      cout<<"0\n";continue;
    }
    dfs(1);cout<<dp[1][m]<<"\n";
  }
}

posted @ 2012-11-23 20:31  剑不飞  阅读(130)  评论(0编辑  收藏  举报