大数变形版斐波那契
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
Input
Each line will contain an integers. Process to end of file.
Output
For each case, output the result in a line.
**Sample Input
1**00
Sample Output
4203968145672990846840663646
Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
#include<stdio.h>
#include<string.h>
int a[7500][600];
int main()
{
memset(a,0,sizeof(a));
int i,j,k,n,m;
a[2][0]=1;
a[1][0]=1;
a[3][0]=1;
a[4][0]=1;
int g=0;
for(i=5;i<7500;i++)
{
for(j=0;j<=g;j++)
{
a[i][j]=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
}
for(j=0;j<=g;j++)
{
a[i][j+1]+=a[i][j]/10000;//每位存放10000,一开始存放10,结果超内存
a[i][j]%=10000;
}
if(a[i][g])
{
g++;
}
}
int h;
while(scanf("%d",&h)!=EOF)
{
for(i=g;i>=0;i--)
if(a[h][i]!=0)
break;
printf("%d",a[h][i--]);
for(;i>=0;i--)
printf("%04d",a[h][i]);//不足4位前置0
printf("\n");
}
return 0;
}