杭电 oj 1016 Prime Ring Problem
**
Problem Description
**
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. You are to write a program that completes above process. Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
深搜 递归
全排列加判断条件
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int a[22];
int b[22];
int n,m;
int sushu(int t)
{
for(int i=2;i*i<=t;i++)
{
if(t%i==0)
return 0;
}
return 1;
}
void dfs(int y)
{
if(y==n+1&&sushu(a[1]+a[n])==1)//最后一个与第一个和是不是素数
{
for(int i=1;i<n;i++)
{
printf("%d ",a[i]);
}
printf("%d\n",a[n]);
return ;
}
for(int i=2;i<=n;i++)//全排列
{
if(b[i]==0&&sushu(i+a[y-1])==1)//判断 如果相邻两个的和是不是素数
{
a[y]=i;
b[i]=1;
dfs(y+1);
b[i]=0;//归零 方便下一个递归 使用
}
}
}
int main()
{
int k=0;
while(scanf("%d",&n)!=EOF)
{
memset(b,0,sizeof(b));
memset(a,0,sizeof(a));
printf("Case %d:\n",++k);
if(n==1)
{
printf("1\n");
continue;
}
if(n%2!=0)
{
printf("No Answer\n");
continue;
}
a[1]=1;
dfs(2);
printf("\n");
}
return 0;
}