杭电oj 题目1021Fibonacci Again
Fibonacci Again
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 61062 Accepted Submission(s): 28528
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word “yes” if 3 divide evenly into F(n).
Print the word “no” if not.
Sample Input
0
1
2
3
4
5
Sample Output
no
no
yes
no
no
no
这道题吧 直接计算肯定不行的
由 (a+b)%3=(a%3+b%3)%3
可以得到如下代码
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int test[1000005];
int main()
{
test[0]=7;
test[1]=11;
for(int i=2;i<1000000;i++)
{
test[i]=(test[i-1]%3+test[i-2]%3)%3;
}
int k;
while(scanf("%d",&k)!=EOF)
{
if(test[k]==0)
printf("yes\n");
else
printf("no\n");
}
return 0;
}