HDU 2795 Billboard

Billboard

Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23357 Accepted Submission(s): 9637

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.

Sample Input
3 5 5
2
4
3
3
3

Sample Output
1
2
1
3
-1

Author
hhanger@zju

线段树 还不是很理解 先贴代码吧

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxx=200020;
int tree[maxx*4];
int h,w,n;
void buildtree(int left,int right,int num)//建树
{
    tree[num]=w;//用数组保存 并初始化为 w
    if(left==right)
        return ;
    int mid=(left+right)/2;
    buildtree(left,mid,num*2);
    buildtree(mid+1,right,num*2+1);
}
int treetree(int left,int right,int num,int t)
{
    if(left==right)
    {
        tree[num]-=t;
        return left;
    }
    int mid=(left+right)/2;
    int tt;
    if(tree[num*2]>=t)
        tt=treetree(left,mid,num*2,t);
    else
        tt=treetree(mid+1,right,num*2+1,t);
    tree[num]=(tree[num*2]>tree[num*2+1]?tree[num*2]:tree[num*2+1]);
    return tt;
}
int main()
{
    int t;
    while(scanf("%d%d%d",&h,&w,&n)!=EOF)
    {
        if(h>n) h=n;
        buildtree(1,h,1);
        while(n--)
        {
            scanf("%d",&t);
            if(tree[1]<t)
                printf("-1\n");
            else
                printf("%d\n",treetree(1,h,1,t));
        }
    }
    return 0;
}
posted @ 2017-07-24 20:46  南风古  阅读(77)  评论(0编辑  收藏  举报