HDU 1003 Max Sum(DP,水题)
Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 253355 Accepted Submission(s): 60124
Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
Author
Ignatius.L
简单的DP
题目要求的是连续的最大的和,注意是连续。
知道题意就好办了,可以推出公式 a[i]=max(a[i-1]+b[i],b[i]);
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
int a[100010];
int b[100010];
int t;
scanf("%d",&t);
int num=1;
while(t--)
{
int k;
scanf("%d",&k);
int maxx=-1001,tt;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
for(int i=1;i<=k;i++)
{
scanf("%d",&b[i]);
a[i]=max(a[i-1]+b[i],b[i]);
if(maxx<a[i])
maxx=a[i],tt=i;//记录和的最大值和最后一个的坐标
}
int sum=0,ttt;
for(int j=tt;j>0;j--)
{
sum+=b[j];
if(sum==maxx)
ttt=j;
}
printf("Case %d:\n",num++);
printf("%d %d %d\n",maxx,ttt,tt);
if(t) printf("\n");
}
return 0;
}