HDU 1686 Oulipo(kmp)
Oulipo
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16525 Accepted Submission(s): 6617
Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
用str首字符与buf首字符比较,两种情况,如下
①如果从str首字符一直比到str尾字符都一样,则计数器+1,然后将str首字符移至buf第二个字符
②如果从str首字符开始比,中途有一个不匹配,则str首字符向buf的下一个字符移动,
重复上述两个动作,直到str首位移至buf的L2-L1-1位为止;
直接kmp模板吧
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxx=1e6+10;
int Next[maxx];
char s[maxx],p[maxx];
int len1,len2;
void getnext()
{
int i=0,j=-1;
Next[0]=-1;
while(i<len1)
{
if(j==-1||p[i]==p[j])
{
++i;
++j;
if(p[i]==p[j])
Next[i]=Next[j];
else
Next[i]=j;
}
else
j=Next[j];
}
}
void getkmp()
{
int num=0,i=0,j=0;
while(i<len2)
{
if(j==-1|s[i]==p[j])
{
++i;++j;
if(j==len1)
num++;
}
else
j=Next[j];
}
printf("%d\n",num);
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%s%s",p,s);
len1=strlen(p);
len2=strlen(s);
getnext();
getkmp();
}
return 0;
}