HDU 1711 Number Sequence(KMP)
Number Sequence
Time Limit : 10000/5000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 27 Accepted Submission(s) : 13
Problem Description
Given two sequences of numbers : a[1], a[2], …… , a[N], and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a[N]. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
Source
HDU 2007-Spring Programming Contest
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxx=1e6+10;
int Next[maxx];
int s[maxx],p[maxx];
int len1,len2;
void getnext()
{
int i=0,j=-1;
Next[0]=-1;
while(i<len1)
{
if(j==-1||p[i]==p[j])
{
++i;
++j;
if(p[i]==p[j])
Next[i]=Next[j];
else
Next[i]=j;
}
else
j=Next[j];
}
}
int getkmp()
{
int num=0,i=0,j=0;
while(i<len2)
{
if(j==-1|s[i]==p[j])
{
++i;++j;
if(j==len1)
return i-len1+1;
}
else
j=Next[j];
}
return -1;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&len2,&len1);
for(int i=0;i<len2;i++)
scanf("%d",&s[i]);
for(int i=0;i<len1;i++)
scanf("%d",&p[i]);
getnext();
if(len2<len1)
printf("-1\n");
else
printf("%d\n",getkmp());
}
return 0;
}